Search functionality not working ?

Other discussions not related to the Permanent Portfolio

Moderator: Global Moderator

Post Reply
User avatar
Vil
Executive Member
Executive Member
Posts: 152
Joined: Wed Jan 01, 2020 10:16 am

Search functionality not working ?

Post by Vil » Wed Jan 13, 2021 3:49 am

Hey guys

Apparently I am facing issues when trying to perform Search - tried both as guest and as logged user - both ways ended up with HTTP 500.
Is it only me ?
User avatar
Vil
Executive Member
Executive Member
Posts: 152
Joined: Wed Jan 01, 2020 10:16 am

Re: Search functionality not working ?

Post by Vil » Thu Jan 14, 2021 1:09 pm

Not that anybody cares (or cared), but just for the record - using the generic search functionality (Search box in the top right corner) actually works with all the words except TIPS. That's really weird, though it's 100% reproducible on my side. Oddly enough I was searching for something related to TIPS back then, before my previous post. Anyway...
User avatar
l82start
Global Moderator
Global Moderator
Posts: 2689
Joined: Sun Apr 25, 2010 9:51 pm

Re: Search functionality not working ?

Post by l82start » Thu Jan 14, 2021 1:13 pm

i seem to be having search issues when i test it as well, i will dig deeper when i get a chance this evening..
thanks for the heads up..

tips wont show but other terms will?? that is weird..
Government 2020+ - a BANANA REPUBLIC - if you can keep it

Belief is the death of intelligence. As soon as one believes a doctrine of any sort, or assumes certitude, one stops thinking about that aspect of existence
User avatar
vnatale
Executive Member
Executive Member
Posts: 5337
Joined: Fri Apr 12, 2019 8:56 pm
Location: Massachusetts
Contact:

Re: Search functionality not working ?

Post by vnatale » Thu Jan 14, 2021 1:21 pm

Vil wrote:
Thu Jan 14, 2021 1:09 pm

Not that anybody cares (or cared), but just for the record - using the generic search functionality (Search box in the top right corner) actually works with all the words except TIPS. That's really weird, though it's 100% reproducible on my side. Oddly enough I was searching for something related to TIPS back then, before my previous post. Anyway...


When I did a search on "tips" it took a long time to get to this:

Capture.JPG
Capture.JPG (22.55 KiB) Viewed 72 times



"I only regret that I have but one lap to give to my cats."
User avatar
dualstow
Executive Member
Executive Member
Posts: 11189
Joined: Wed Oct 27, 2010 10:18 am
Contact:

Re: Search functionality not working ?

Post by dualstow » Thu Jan 14, 2021 1:40 pm

Vil wrote:
Wed Jan 13, 2021 3:49 am
Hey guys

Apparently I am facing issues when trying to perform Search - tried both as guest and as logged user - both ways ended up with HTTP 500.
Is it only me ?
Not just you.
i often type my search terms into google

Code: Select all

 chaps site:gyroscopicinvesting.com
"It’s easy to be a communist in a free country. But try being free in a communist country." - @vtchakarova
WhatsApp users can no longer opt out of having their data sent to facebook -Schneier blog
User avatar
Vil
Executive Member
Executive Member
Posts: 152
Joined: Wed Jan 01, 2020 10:16 am

Re: Search functionality not working ?

Post by Vil » Thu Jan 14, 2021 2:14 pm

Thanks guys, thanks l82start !
It's weird indeed, actually, it may have a relation with the way a search term is indexed by phpBB (e.g. "Trump" takes half of the index-tree ;D ) ..
But you know better - thanks again!
User avatar
pugchief
Executive Member
Executive Member
Posts: 4245
Joined: Tue Jun 26, 2012 2:41 pm
Location: suburbs of Chicago, IL

Re: Search functionality not working ?

Post by pugchief » Thu Jan 14, 2021 5:40 pm

Here's another problem I have been experiencing periodically over the last few days and from different PCs:

I usually access the forum from the "Unread Posts" page on the hamburger menu at the upper left. By clicking on the red circle to the left of the thread, it used to bring you to the last unread post (that I personally read) in that thread. Now, every few threads, if I click on the red circle it will bring me to some random post on some random page in the thread instead of the last unread one.

Is anyone else having this issue? Can one of the mods look into it please?
User avatar
l82start
Global Moderator
Global Moderator
Posts: 2689
Joined: Sun Apr 25, 2010 9:51 pm

Re: Search functionality not working ?

Post by l82start » Thu Jan 14, 2021 5:41 pm

pugchief wrote:
Thu Jan 14, 2021 5:40 pm
Here's another problem I have been experiencing periodically over the last few days and from different PCs:

I usually access the forum from the "Unread Posts" page on the hamburger menu at the upper left. By clicking on the red circle to the left of the thread, it used to bring you to the last unread post (that I personally read) in that thread. Now, every few threads, if I click on the red circle it will bring me to some random post on some random page in the thread instead of the last unread one.

Is anyone else having this issue? Can one of the mods look into it please?
ditto also having this issue starting today...
Government 2020+ - a BANANA REPUBLIC - if you can keep it

Belief is the death of intelligence. As soon as one believes a doctrine of any sort, or assumes certitude, one stops thinking about that aspect of existence
User avatar
vnatale
Executive Member
Executive Member
Posts: 5337
Joined: Fri Apr 12, 2019 8:56 pm
Location: Massachusetts
Contact:

Re: Search functionality not working ?

Post by vnatale » Thu Jan 14, 2021 5:56 pm

pugchief wrote:
Thu Jan 14, 2021 5:40 pm

Here's another problem I have been experiencing periodically over the last few days and from different PCs:

I usually access the forum from the "Unread Posts" page on the hamburger menu at the upper left. By clicking on the red circle to the left of the thread, it used to bring you to the last unread post (that I personally read) in that thread. Now, every few threads, if I click on the red circle it will bring me to some random post on some random page in the thread instead of the last unread one.

Is anyone else having this issue? Can one of the mods look into it please?


Same just happened to me in the last hour or so.

But that feature has well proven to be unreliable in the past so I'm always checking it to look at the last prior post to make sure I am starting with the last unread one. It is almost always the last unread one but I do catch the ones that are not and go back to truly find the last unread one.

"I only regret that I have but one lap to give to my cats."
User avatar
Kriegsspiel
Executive Member
Executive Member
Posts: 3287
Joined: Sun Sep 16, 2012 5:28 pm

Re: Search functionality not working ?

Post by Kriegsspiel » Thu Jan 14, 2021 6:38 pm

I've always had problems with search. I just assumed it was a feature of this forum software.
I hated all the things I had toiled for under the sun, because I must leave them to the one who comes after me. Who knows whether that person will be wise or foolish? Yet they will have control over all the fruit of my toil into which I have poured my effort and skill under the sun. . . Nothing is better for a man than to eat and drink and enjoy his work.
- Ecclesiastes
User avatar
l82start
Global Moderator
Global Moderator
Posts: 2689
Joined: Sun Apr 25, 2010 9:51 pm

Re: Search functionality not working ?

Post by l82start » Thu Jan 14, 2021 6:50 pm

i think it gets buggy every now and then during updates-modifications and times with heavy post/thread movement. i will have to ask xan our tech expert, but if i remember correctly there is a reset/re-compile button somewhere in the admin controls that needs to be run periodically to sort it back out..
Government 2020+ - a BANANA REPUBLIC - if you can keep it

Belief is the death of intelligence. As soon as one believes a doctrine of any sort, or assumes certitude, one stops thinking about that aspect of existence
Post Reply